What’s Vulnerable › Vulnerabilities
CVE-2019-9637
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-09 · updated 2026-06-17
- Weakness: CWE-264
Description
An issue was discovered in PHP before 7.1.27, 7.2.x before 7.2.16, and 7.3.x before 7.3.3. Due to the way rename() across filesystems is implemented, it is possible that file being renamed is briefly available with wrong permissions while the rename is ongoing, thus enabling unauthorized users to access the data.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- NetApp Storage Automation Store: all versions
- openSUSE Leap: 42.3
- PHP: before 7.1.27; from 7.2.0 before 7.2.16; from 7.3.0 before 7.3.3 — fixed in 7.1.27, 7.2.16, 7.3.3
How to fix
Upgrade to a fixed version: PHP 7.1.27, 7.2.16, 7.3.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html
- https://access.redhat.com/errata/RHSA-2019:2519
- https://access.redhat.com/errata/RHSA-2019:3299
- https://bugs.php.net/bug.php?id=77630
- https://lists.debian.org/debian-lts-announce/2019/03/msg00043.html
- https://security.netapp.com/advisory/ntap-20190502-0007/
- https://support.f5.com/csp/article/K53825211
- https://usn.ubuntu.com/3922-1/
- https://usn.ubuntu.com/3922-2/
Get alerted when CVE-2019-9637 or the next vulnerability affects your stack