What’s Vulnerable › Vulnerabilities
CVE-2019-9641
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-09 · updated 2026-06-17
- Weakness: CWE-908
Description
An issue was discovered in the EXIF component in PHP before 7.1.27, 7.2.x before 7.2.16, and 7.3.x before 7.3.3. There is an uninitialized read in exif_process_IFD_in_TIFF.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- NetApp Storage Automation Store: all versions
- openSUSE Leap: 15.0, 15.1, 42.3
- PHP: before 7.1.27; from 7.2.0 before 7.2.16; from 7.3.0 before 7.3.3 — fixed in 7.1.27, 7.2.16, 7.3.3
How to fix
Upgrade to a fixed version: PHP 7.1.27, 7.2.16, 7.3.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00083.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html
- https://bugs.php.net/bug.php?id=77509
- https://lists.debian.org/debian-lts-announce/2019/03/msg00043.html
- https://security.netapp.com/advisory/ntap-20190502-0007/
- https://usn.ubuntu.com/3922-1/
- https://usn.ubuntu.com/3922-2/
- https://usn.ubuntu.com/3922-3/
- https://www.debian.org/security/2019/dsa-4403
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00083.html
Get alerted when CVE-2019-9641 or the next vulnerability affects your stack