What’s Vulnerable › Vulnerabilities
CVE-2019-9646
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Contact Form Email plugin before 1.2.66 for WordPress allows wp-admin/admin.php item XSS, related to cp_admin_int_edition.inc.php in the "custom edition area."
Affected products
- codepeople Contact Form Email: before 1.2.66 — fixed in 1.2.66
How to fix
Upgrade to a fixed version: codepeople Contact Form Email 1.2.66. Check the vendor advisory for mitigations.
References
- https://lists.openwall.net/full-disclosure/2019/02/05/7
- https://security-consulting.icu/blog/2019/02/wordpress-contact-form-email-xss-csrf/
- https://wordpress.org/plugins/contact-form-to-email/#developers
- https://lists.openwall.net/full-disclosure/2019/02/05/7
- https://security-consulting.icu/blog/2019/02/wordpress-contact-form-email-xss-csrf/
- https://wordpress.org/plugins/contact-form-to-email/#developers
Get alerted when CVE-2019-9646 or the next vulnerability affects your stack