What’s Vulnerable › Vulnerabilities
CVE-2019-9675
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-11 · updated 2026-06-17
- Weakness: CWE-119
Description
An issue was discovered in PHP 7.x before 7.1.27 and 7.3.x before 7.3.3. phar_tar_writeheaders_int in ext/phar/tar.c has a buffer overflow via a long link value. NOTE: The vendor indicates that the link value is used only when an archive contains a symlink, which currently cannot happen: "This issue allows theoretical compromise of security, but a practical attack is usually impossible.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04
- openSUSE Leap: 42.3
- PHP: from 7.0.0 before 7.1.27; from 7.3.0 before 7.3.3 — fixed in 7.1.27, 7.3.3
How to fix
Upgrade to a fixed version: PHP 7.1.27, 7.3.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html
- http://php.net/ChangeLog-7.php
- https://bugs.php.net/bug.php?id=77586
- https://usn.ubuntu.com/3922-2/
- https://usn.ubuntu.com/3922-3/
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html
Get alerted when CVE-2019-9675 or the next vulnerability affects your stack