What’s Vulnerable › Vulnerabilities
CVE-2019-9705
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-12 · updated 2026-06-17
- Weakness: CWE-770
Description
Vixie Cron before the 3.0pl1-133 Debian package allows local users to cause a denial of service (memory consumption) via a large crontab file because an unlimited number of lines is accepted.
Affected products
- Cron Project Cron: before 3.0pl1-133 — fixed in 3.0pl1-133
- Debian Linux: 8.0, 9.0
- Fedoraproject Fedora: 29
How to fix
Upgrade to a fixed version: Cron Project Cron 3.0pl1-133. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107378
- https://lists.debian.org/debian-lts-announce/2019/03/msg00025.html
- https://lists.debian.org/debian-lts-announce/2021/10/msg00029.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6DU7HAUAQR4E4AEBPYLUV6FZ4PHKH6A2/
- https://salsa.debian.org/debian/cron/commit/26814a26
- http://www.securityfocus.com/bid/107378
- https://lists.debian.org/debian-lts-announce/2019/03/msg00025.html
- https://lists.debian.org/debian-lts-announce/2021/10/msg00029.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6DU7HAUAQR4E4AEBPYLUV6FZ4PHKH6A2/
- https://salsa.debian.org/debian/cron/commit/26814a26
Get alerted when CVE-2019-9705 or the next vulnerability affects your stack