What’s Vulnerable › Vulnerabilities
CVE-2019-9712
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-12 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in Joomla! before 3.9.4. The JSON handler in com_config lacks input validation, leading to XSS.
Affected products
- Joomla!: from 3.2.0 before 3.9.4 — fixed in 3.9.4
How to fix
Upgrade to a fixed version: Joomla! 3.9.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107374
- https://developer.joomla.org/security-centre/772-20190301-core-xss-in-com-config-json-handler
- http://www.securityfocus.com/bid/107374
- https://developer.joomla.org/security-centre/772-20190301-core-xss-in-com-config-json-handler
Get alerted when CVE-2019-9712 or the next vulnerability affects your stack