What’s Vulnerable › Vulnerabilities
CVE-2019-9787
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 38.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-14 · updated 2026-06-17
- Weakness: CWE-352
Description
WordPress before 5.1.1 does not properly filter comment content, leading to Remote Code Execution by unauthenticated users in a default configuration. This occurs because CSRF protection is mishandled, and because Search Engine Optimization of A elements is performed incorrectly, leading to XSS. The XSS results in administrative access, which allows arbitrary changes to .php files. This is related to wp-admin/includes/ajax-actions.php and wp-includes/comment.php.
Affected products
- WordPress: before 5.1.1 — fixed in 5.1.1
How to fix
Upgrade to a fixed version: WordPress 5.1.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107411
- https://blog.ripstech.com/2019/wordpress-csrf-to-rce/
- https://github.com/WordPress/WordPress/commit/0292de60ec78c5a44956765189403654fe4d080b
- https://lists.debian.org/debian-lts-announce/2019/03/msg00044.html
- https://wordpress.org/news/2019/03/wordpress-5-1-1-security-and-maintenance-release/
- https://wordpress.org/support/wordpress-version/version-5-1-1/
- https://wpvulndb.com/vulnerabilities/9230
- https://www.debian.org/security/2020/dsa-4677
- http://www.securityfocus.com/bid/107411
- https://blog.ripstech.com/2019/wordpress-csrf-to-rce/
- https://github.com/WordPress/WordPress/commit/0292de60ec78c5a44956765189403654fe4d080b
- https://lists.debian.org/debian-lts-announce/2019/03/msg00044.html
Get alerted when CVE-2019-9787 or the next vulnerability affects your stack