What’s Vulnerable › Vulnerabilities
CVE-2019-9795
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-26 · updated 2026-06-17
- Weakness: CWE-617
Description
A vulnerability where type-confusion in the IonMonkey just-in-time (JIT) compiler could potentially be used by malicious JavaScript to trigger a potentially exploitable crash. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.
Affected products
- Mozilla Firefox: before 66.0 — fixed in 66.0
- Mozilla Firefox ESR: before 60.6 — fixed in 60.6
- Mozilla Thunderbird: before 60.6 — fixed in 60.6
How to fix
Upgrade to a fixed version: Mozilla Firefox 66.0; Mozilla Firefox ESR 60.6; Mozilla Thunderbird 60.6. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:0966
- https://access.redhat.com/errata/RHSA-2019:1144
- https://bugzilla.mozilla.org/show_bug.cgi?id=1514682
- https://www.mozilla.org/security/advisories/mfsa2019-07/
- https://www.mozilla.org/security/advisories/mfsa2019-08/
- https://www.mozilla.org/security/advisories/mfsa2019-11/
- https://access.redhat.com/errata/RHSA-2019:0966
- https://access.redhat.com/errata/RHSA-2019:1144
- https://bugzilla.mozilla.org/show_bug.cgi?id=1514682
- https://www.mozilla.org/security/advisories/mfsa2019-07/
- https://www.mozilla.org/security/advisories/mfsa2019-08/
- https://www.mozilla.org/security/advisories/mfsa2019-11/
Get alerted when CVE-2019-9795 or the next vulnerability affects your stack