What’s Vulnerable › Vulnerabilities
CVE-2019-9798
- Severity: high (CVSS 7.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-26 · updated 2026-06-17
- Weakness: CWE-426
Description
On Android systems, Firefox can load a library from APITRACE_LIB, which is writable by all users and applications. This could allow malicious third party applications to execute a man-in-the-middle attack if a malicious code was written to that location and loaded. *Note: This issue only affects Android. Other operating systems are unaffected.*. This vulnerability affects Firefox < 66.
Affected products
- Mozilla Firefox: before 66.0 — fixed in 66.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 66.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1527534
- https://www.mozilla.org/security/advisories/mfsa2019-07/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1527534
- https://www.mozilla.org/security/advisories/mfsa2019-07/
Get alerted when CVE-2019-9798 or the next vulnerability affects your stack