What’s Vulnerable › Vulnerabilities
CVE-2019-9823
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-03 · updated 2026-06-17
- Weakness: CWE-312
Description
In several JetBrains IntelliJ IDEA versions, creating remote run configurations of JavaEE application servers leads to saving a cleartext record of the server credentials in the IDE configuration files. The issue has been fixed in the following versions: 2018.3.5, 2018.2.8, 2018.1.8.
Affected products
- JetBrains IntelliJ IDEA: from 2018.1 before 2018.1.8; from 2018.2 before 2018.2.8; from 2018.3 before 2018.3.5 — fixed in 2018.1.8, 2018.2.8, 2018.3.5
How to fix
Upgrade to a fixed version: JetBrains IntelliJ IDEA 2018.1.8, 2018.2.8, 2018.3.5. Check the vendor advisory for mitigations.
References
- https://blog.jetbrains.com/blog/2019/06/19/jetbrains-security-bulletin-q1-2019/
- https://blog.jetbrains.com/blog/2019/06/19/jetbrains-security-bulletin-q1-2019/
Get alerted when CVE-2019-9823 or the next vulnerability affects your stack