What’s Vulnerable › Vulnerabilities
CVE-2019-9837
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-21 · updated 2026-06-17
- Weakness: CWE-601
Description
Doorkeeper::OpenidConnect (aka the OpenID Connect extension for Doorkeeper) 1.4.x and 1.5.x before 1.5.4 has an open redirect via the redirect_uri field in an OAuth authorization request (that results in an error response) with the 'openid' scope and a prompt=none value. This allows phishing attacks against the authorization flow.
Affected products
- OpenID Connect: from 1.4.0 before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: OpenID Connect 1.5.4. Check the vendor advisory for mitigations.
References
- https://github.com/doorkeeper-gem/doorkeeper-openid_connect/blob/master/CHANGELOG.md
- https://github.com/doorkeeper-gem/doorkeeper-openid_connect/issues/61
- https://github.com/doorkeeper-gem/doorkeeper-openid_connect/pull/66
- https://github.com/doorkeeper-gem/doorkeeper-openid_connect/blob/master/CHANGELOG.md
- https://github.com/doorkeeper-gem/doorkeeper-openid_connect/issues/61
- https://github.com/doorkeeper-gem/doorkeeper-openid_connect/pull/66
Get alerted when CVE-2019-9837 or the next vulnerability affects your stack