What’s Vulnerable › Vulnerabilities
CVE-2019-9852: Insufficient URL encoding flaw in allowed script location check
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-15 · updated 2026-06-17
- Weakness: CWE-116
Description
LibreOffice has a feature where documents can specify that pre-installed macros can be executed on various script events such as mouse-over, document-open etc. Access is intended to be restricted to scripts under the share/Scripts/python, user/Scripts/python sub-directories of the LibreOffice install. Protection was added, to address CVE-2018-16858, to avoid a directory traversal attack where scripts in arbitrary locations on the file system could be executed. However this new protection could be bypassed by a URL encoding attack. In the fixed versions, the parsed url describing the script location is correctly encoded before further processing. This issue affects: Document Foundation LibreOffice versions prior to 6.2.6.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.04
- Debian Linux: 8.0, 9.0, 10.0
- Fedoraproject Fedora: 29
- The Document Foundation LibreOffice: before 6.2.6 — fixed in 6.2.6
- openSUSE Leap: 15.0, 15.1
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 6.2.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00067.html
- https://lists.debian.org/debian-lts-announce/2019/10/msg00005.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PMEGUWMWORC3DOVEHVXLFT3A5RSCMLBH/
- https://seclists.org/bugtraq/2019/Aug/28
- https://seclists.org/bugtraq/2019/Sep/17
- https://usn.ubuntu.com/4102-1/
- https://www.debian.org/security/2019/dsa-4501
- https://www.libreoffice.org/about-us/security/advisories/CVE-2019-9852
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00006.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00067.html
- https://lists.debian.org/debian-lts-announce/2019/10/msg00005.html
Get alerted when CVE-2019-9852 or the next vulnerability affects your stack