What’s Vulnerable › Vulnerabilities
CVE-2019-9896
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-21 · updated 2026-06-17
- Weakness: CWE-427
Description
In PuTTY versions before 0.71 on Windows, local attackers could hijack the application by putting a malicious help file in the same directory as the executable.
Affected products
- openSUSE Backports Sle: 15.0
- openSUSE Leap: 15.0
- PuTTY: before 0.71 — fixed in 0.71
How to fix
Upgrade to a fixed version: PuTTY 0.71. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00020.html
- https://security.netapp.com/advisory/ntap-20190404-0001/
- https://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00020.html
- https://security.netapp.com/advisory/ntap-20190404-0001/
- https://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html
Get alerted when CVE-2019-9896 or the next vulnerability affects your stack