What’s Vulnerable › Vulnerabilities
CVE-2019-9897
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-21 · updated 2026-06-17
Description
Multiple denial-of-service attacks that can be triggered by writing to the terminal exist in PuTTY versions before 0.71.
Affected products
- Debian Linux: 8.0, 9.0
- Fedoraproject Fedora: 28, 29
- NetApp OnCommand Unified Manager for 7-Mode (core package): all versions
- openSUSE Leap: 15.0
- PuTTY: before 0.71 — fixed in 0.71
How to fix
Upgrade to a fixed version: PuTTY 0.71. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00020.html
- https://lists.debian.org/debian-lts-announce/2019/04/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/36LWQ3NPFIV7DC7TC4KFPRYRH2OR7SZ2/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LDO3F267P347E6U2IILFCYW7JPTLCCES/
- https://seclists.org/bugtraq/2019/Apr/6
- https://security.netapp.com/advisory/ntap-20190404-0001/
- https://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html
- https://www.debian.org/security/2019/dsa-4423
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00004.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00020.html
- https://lists.debian.org/debian-lts-announce/2019/04/msg00023.html
Get alerted when CVE-2019-9897 or the next vulnerability affects your stack