What’s Vulnerable › Vulnerabilities
CVE-2019-9924
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-22 · updated 2026-06-17
- Weakness: CWE-862
Description
rbash in Bash before 4.4-beta2 did not prevent the shell user from modifying BASH_CMDS, thus allowing the user to execute any command with the permissions of the shell.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04
- Debian Linux: 8.0
- GNU Bash: before 4.4; 4.4-beta1 — fixed in 4.4
- NetApp Hci Management Node: all versions
- NetApp Solidfire: all versions
- openSUSE Leap: 42.3
How to fix
Upgrade to a fixed version: GNU Bash 4.4. Check the vendor advisory for mitigations.
References
- http://git.savannah.gnu.org/cgit/bash.git/tree/CHANGES?h=bash-4.4-testing#n65
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00049.html
- https://bugs.launchpad.net/ubuntu/+source/bash/+bug/1803441
- https://lists.debian.org/debian-lts-announce/2019/03/msg00028.html
- https://security.netapp.com/advisory/ntap-20190411-0001/
- https://usn.ubuntu.com/4058-1/
- https://usn.ubuntu.com/4058-2/
- http://git.savannah.gnu.org/cgit/bash.git/tree/CHANGES?h=bash-4.4-testing#n65
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00049.html
- https://bugs.launchpad.net/ubuntu/+source/bash/+bug/1803441
- https://lists.debian.org/debian-lts-announce/2019/03/msg00028.html
- https://security.netapp.com/advisory/ntap-20190411-0001/
Get alerted when CVE-2019-9924 or the next vulnerability affects your stack