What’s Vulnerable › Vulnerabilities
CVE-2019-9928
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-24 · updated 2026-06-17
- Weakness: CWE-787
Description
GStreamer before 1.16.0 has a heap-based buffer overflow in the RTSP connection parser via a crafted response from a server, potentially allowing remote code execution.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- GStreamer: before 1.16.0 — fixed in 1.16.0
How to fix
Upgrade to a fixed version: GStreamer 1.16.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00078.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00082.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00049.html
- https://gstreamer.freedesktop.org/security/
- https://gstreamer.freedesktop.org/security/sa-2019-0001.html
- https://lists.debian.org/debian-lts-announce/2019/04/msg00030.html
- https://lists.debian.org/debian-lts-announce/2019/04/msg00031.html
- https://seclists.org/bugtraq/2019/Apr/39
- https://security.gentoo.org/glsa/202003-33
- https://usn.ubuntu.com/3958-1/
- https://www.debian.org/security/2019/dsa-4437
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00078.html
Get alerted when CVE-2019-9928 or the next vulnerability affects your stack