What’s Vulnerable › Vulnerabilities
CVE-2019-9978: WordPress Social Warfare Plugin Cross-Site Scripting (XSS) Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 72.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The social-warfare plugin before 3.5.3 for WordPress has stored XSS via the wp-admin/admin-post.php?swp_debug=load_options swp_url parameter, as exploited in the wild in March 2019. This affects Social Warfare and Social Warfare Pro.
Affected products
- warfareplugins Social Sharing Plugin – Social Warfare: before 3.5.3 — fixed in 3.5.3
- warfareplugins Social Warfare Pro: before 3.5.3 — fixed in 3.5.3
How to fix
Upgrade to a fixed version: warfareplugins Social Sharing Plugin – Social Warfare 3.5.3; warfareplugins Social Warfare Pro 3.5.3. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/152722/Wordpress-Social-Warfare-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/163680/WordPress-Social-Warfare-3.5.2-Remote-Code-Execution.html
- https://blog.sucuri.net/2019/03/zero-day-stored-xss-in-social-warfare.html
- https://twitter.com/warfareplugins/status/1108852747099652099
- https://wordpress.org/plugins/social-warfare/#developers
- https://wpvulndb.com/vulnerabilities/9238
- https://www.cybersecurity-help.cz/vdb/SB2019032105
- https://www.exploit-db.com/exploits/46794/
- https://www.pluginvulnerabilities.com/2019/03/21/full-disclosure-of-settings-change-persistent-cross-site-scripting-xss-vulnerability-in-social-warfare/
- https://www.wordfence.com/blog/2019/03/unpatched-zero-day-vulnerability-in-social-warfare-plugin-exploited-in-the-wild/
- http://packetstormsecurity.com/files/152722/Wordpress-Social-Warfare-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/163680/WordPress-Social-Warfare-3.5.2-Remote-Code-Execution.html
Get alerted when CVE-2019-9978 or the next vulnerability affects your stack