What’s Vulnerable › Vulnerabilities
CVE-2020-10018
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-02 · updated 2026-06-17
- Weakness: CWE-416
Description
WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.
Affected products
- Canonical Ubuntu Linux: 18.04, 19.10
- Debian Linux: 10.0
- Fedoraproject Fedora: 30, 31
- openSUSE Leap: 15.1
- Webkit: before 2.28.0 — fixed in 2.28.0
- Wpewebkit Wpe Webkit: before 2.28.0 — fixed in 2.28.0
How to fix
Upgrade to a fixed version: Webkit 2.28.0; Wpewebkit Wpe Webkit 2.28.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00008.html
- https://bugs.webkit.org/show_bug.cgi?id=204342#c21
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DOR5LPL4UASVAR76EIHCL4O2KGDWGC6K/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GLERWAS2LL7SX2GHA2DDZ2PL3QC5OHIF/
- https://security.gentoo.org/glsa/202006-08
- https://usn.ubuntu.com/4310-1/
- https://webkitgtk.org/security/WSA-2020-0003.html
- https://wpewebkit.org/security/WSA-2020-0003.html
- https://www.debian.org/security/2020/dsa-4641
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00008.html
- https://bugs.webkit.org/show_bug.cgi?id=204342#c21
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DOR5LPL4UASVAR76EIHCL4O2KGDWGC6K/
Get alerted when CVE-2020-10018 or the next vulnerability affects your stack