What’s Vulnerable › Vulnerabilities
CVE-2020-10128: SearchBlox product before V-9.2.1 is vulnerable to Stored-Cross Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-05 · updated 2026-06-17
- Weakness: CWE-79
Description
SearchBlox product with version before 9.2.1 is vulnerable to stored cross-site scripting at multiple user input parameters. In SearchBlox products multiple parameters are not sanitized/validate properly which allows an attacker to inject malicious JavaScript.
Affected products
- SearchBlox: before 9.2.1 — fixed in 9.2.1
How to fix
Upgrade to a fixed version: SearchBlox 9.2.1. Check the vendor advisory for mitigations.
References
- https://developer.searchblox.com/v9.2/changelog/version-921
- https://developer.searchblox.com/v9.2/changelog/version-921
Get alerted when CVE-2020-10128 or the next vulnerability affects your stack