What’s Vulnerable › Vulnerabilities
CVE-2020-10187: Exposure of Sensitive Information to an Unauthorized Actor in Doorkeeper
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-04 · updated 2026-06-17
- Weakness: CWE-862
Description
Doorkeeper version 5.0.0 and later contains an information disclosure vulnerability that allows an attacker to retrieve the client secret only intended for the OAuth application owner. After authorizing the application and allowing access, the attacker simply needs to request the list of their authorized applications in a JSON format (usually GET /oauth/authorized_applications.json). An application is vulnerable if the authorized applications controller is enabled.
Affected products
- doorkeeper-gem doorkeeper: from 5.0.0 before 5.0.3; from 5.1.0 before 5.1.1; from 5.2.0 before 5.2.5; from 5.3.0 before 5.3.2 — fixed in 5.0.3, 5.1.1, 5.2.5, 5.3.2
- Rubygems Doorkeeper: from 5.0.0 before 5.0.3; from 5.1.0 before 5.1.1; from 5.2.0 before 5.2.5; from 5.3.0 before 5.3.2; 5.0.0, 5.0.1, 5.0.2, 5.1.0, 5.2.0, 5.2.1 (+5) — fixed in 5.0.3, 5.1.1, 5.2.5, 5.3.2
How to fix
Upgrade to a fixed version: doorkeeper-gem doorkeeper 5.0.3, 5.1.1, 5.2.5, 5.3.2; Rubygems Doorkeeper 5.0.3, 5.1.1, 5.2.5, 5.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/doorkeeper-gem/doorkeeper/commit/25d038022c2fcad45af5b73f9d003cf38ff491f6
- https://github.com/doorkeeper-gem/doorkeeper/releases
- https://github.com/doorkeeper-gem/doorkeeper/security/advisories/GHSA-j7vx-8mqj-cqp9
- https://github.com/rubysec/ruby-advisory-db/pull/446
- https://github.com/doorkeeper-gem/doorkeeper/commit/25d038022c2fcad45af5b73f9d003cf38ff491f6
- https://github.com/doorkeeper-gem/doorkeeper/releases
- https://github.com/doorkeeper-gem/doorkeeper/security/advisories/GHSA-j7vx-8mqj-cqp9
- https://github.com/rubysec/ruby-advisory-db/pull/446
Get alerted when CVE-2020-10187 or the next vulnerability affects your stack