What’s Vulnerable › Vulnerabilities
CVE-2020-10195
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-13 · updated 2026-06-17
- Weakness: CWE-200
Description
The popup-builder plugin before 3.64.1 for WordPress allows information disclosure and settings modification, leading to in-scope privilege escalation via admin-post actions to com/classes/Actions.php. By sending a POST request to wp-admin/admin-post.php, an authenticated attacker with minimal (subscriber-level) permissions can modify the plugin's settings to allow arbitrary roles (including subscribers) access to plugin functionality by setting the action parameter to sgpbSaveSettings, export a list of current newsletter subscribers by setting the action parameter to csv_file, or obtain system configuration information including webserver configuration and a list of installed plugins by setting the action parameter to sgpb_system_info.
Affected products
- Popup Builder: before 3.64.1 — fixed in 3.64.1
How to fix
Upgrade to a fixed version: Popup Builder 3.64.1. Check the vendor advisory for mitigations.
References
- https://wpvulndb.com/vulnerabilities/10127
- https://www.wordfence.com/blog/2020/03/vulnerabilities-patched-in-popup-builder-plugin-affecting-over-100000-sites/
- https://wpvulndb.com/vulnerabilities/10127
- https://www.wordfence.com/blog/2020/03/vulnerabilities-patched-in-popup-builder-plugin-affecting-over-100000-sites/
Get alerted when CVE-2020-10195 or the next vulnerability affects your stack