What’s Vulnerable › Vulnerabilities
CVE-2020-10372
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Ramp AltitudeCDN Altimeter before 2.4.0 allows authenticated Stored XSS via the vdms/ipmapping.jsp location field to the dms/rest/services/datastore/createOrEditValueForKey URI.
Affected products
- Ramp Altimeter: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: Ramp Altimeter 2.4.0. Check the vendor advisory for mitigations.
References
- https://labs.f-secure.com/advisories/ramp-altimeter-stored-xss/
- https://labs.f-secure.com/advisories/ramp-altimeter-stored-xss/
Get alerted when CVE-2020-10372 or the next vulnerability affects your stack