What’s Vulnerable › Vulnerabilities
CVE-2020-10516: Improper access control in GitHub Enterprise Server leading to privilege escalation of organization member
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-03 · updated 2026-06-17
- Weakness: CWE-285
Description
An improper access control vulnerability was identified in the GitHub Enterprise Server API that allowed an organization member to escalate permissions and gain access to unauthorized repositories within an organization. This vulnerability affected all versions of GitHub Enterprise Server prior to 2.21 and was fixed in 2.20.9, 2.19.15, and 2.18.20. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- Github: from 2.18.0 before 2.18.20; from 2.19.0 before 2.19.15; from 2.20.0 before 2.20.9 — fixed in 2.18.20, 2.19.15, 2.20.9
How to fix
Upgrade to a fixed version: Github 2.18.20, 2.19.15, 2.20.9. Check the vendor advisory for mitigations.
References
- https://enterprise.github.com/releases/2.18.20/notes
- https://enterprise.github.com/releases/2.19.15/notes
- https://enterprise.github.com/releases/2.20.9/notes
- https://enterprise.github.com/releases/2.18.20/notes
- https://enterprise.github.com/releases/2.19.15/notes
- https://enterprise.github.com/releases/2.20.9/notes
Get alerted when CVE-2020-10516 or the next vulnerability affects your stack