What’s Vulnerable › Vulnerabilities
CVE-2020-10568
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-14 · updated 2026-06-17
- Weakness: CWE-352
Description
The sitepress-multilingual-cms (WPML) plugin before 4.3.7-b.2 for WordPress has CSRF due to a loose comparison. This leads to remote code execution in includes/class-wp-installer.php via a series of requests that leverage unintended comparisons of integers to strings.
Affected products
- OnTheGoSystems Sitepress-Multilingual-Cms: before 4.3.7; 4.3.7-b.1 — fixed in 4.3.7
How to fix
Upgrade to a fixed version: OnTheGoSystems Sitepress-Multilingual-Cms 4.3.7. Check the vendor advisory for mitigations.
References
- https://medium.com/%40arall/sitepress-multilingual-cms-wplugin-wpml-4-3-7-b-2-9c9486c13577
- https://wpvulndb.com/vulnerabilities/10131
- https://medium.com/%40arall/sitepress-multilingual-cms-wplugin-wpml-4-3-7-b-2-9c9486c13577
- https://wpvulndb.com/vulnerabilities/10131
Get alerted when CVE-2020-10568 or the next vulnerability affects your stack