What’s Vulnerable › Vulnerabilities
CVE-2020-10571
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-14 · updated 2026-06-17
- Weakness: CWE-754
Description
An issue was discovered in psd-tools before 1.9.4. The Cython implementation of RLE decoding did not check for malicious data.
Affected products
- psd-tools: before 1.9.4 — fixed in 1.9.4
How to fix
Upgrade to a fixed version: psd-tools 1.9.4. Check the vendor advisory for mitigations.
References
- https://github.com/psd-tools/psd-tools/pull/198
- https://github.com/psd-tools/psd-tools/releases/tag/v1.9.4
- https://github.com/psd-tools/psd-tools/pull/198
- https://github.com/psd-tools/psd-tools/releases/tag/v1.9.4
Get alerted when CVE-2020-10571 or the next vulnerability affects your stack