What’s Vulnerable › Vulnerabilities
CVE-2020-10657
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-06 · updated 2026-06-17
- Weakness: CWE-502
Description
The Proofpoint Insider Threat Management Server (formerly ObserveIT Server) before 7.9.1 contains a vulnerability in the ITM web console's ImportAlertRules feature. The vulnerability allows a remote attacker (with admin or config-admin privileges in the console) to execute arbitrary code with local administrator privileges. The vulnerability is caused by improper deserialization.
Affected products
- Proofpoint Insider Threat Management: before 7.9.1 — fixed in 7.9.1
How to fix
Upgrade to a fixed version: Proofpoint Insider Threat Management 7.9.1. Check the vendor advisory for mitigations.
References
- https://www.proofpoint.com/us/blog
- https://www.proofpoint.com/us/security/security-advisories/pfpt-sa-2020-0003
- https://www.proofpoint.com/us/blog
- https://www.proofpoint.com/us/security/security-advisories/pfpt-sa-2020-0003
Get alerted when CVE-2020-10657 or the next vulnerability affects your stack