What’s Vulnerable › Vulnerabilities
CVE-2020-10675
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-19 · updated 2026-06-17
- Weakness: CWE-835
Description
The Library API in buger jsonparser through 2019-12-04 allows attackers to cause a denial of service (infinite loop) via a Delete call.
Affected products
- Fedoraproject Fedora: 31, 32
- github.com/buger/jsonparser: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: github.com/buger/jsonparser 1.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/buger/jsonparser/issues/188
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4C7PV6KEUUM76V4B2J5IFN2U6LEOWB67/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6KUHKDQSEYJNROA66OMN6AAQMGAAN6WI/
- https://github.com/buger/jsonparser/issues/188
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4C7PV6KEUUM76V4B2J5IFN2U6LEOWB67/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6KUHKDQSEYJNROA66OMN6AAQMGAAN6WI/
Get alerted when CVE-2020-10675 or the next vulnerability affects your stack