What’s Vulnerable › Vulnerabilities
CVE-2020-10678
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-19 · updated 2026-06-17
Description
In Octopus Deploy before 2020.1.5, for customers running on-premises Active Directory linked to their Octopus server, an authenticated user can leverage a bug to escalate privileges.
Affected products
- Octopus Deploy: before 2020.1.5 — fixed in 2020.1.5
How to fix
Upgrade to a fixed version: Octopus Deploy 2020.1.5. Check the vendor advisory for mitigations.
References
- https://github.com/OctopusDeploy/Issues/issues/6258
- https://github.com/OctopusDeploy/Issues/issues/6258
Get alerted when CVE-2020-10678 or the next vulnerability affects your stack