What’s Vulnerable › Vulnerabilities

CVE-2020-10684

Description

A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled, overwriting the ansible_facts after the clean. An attacker could take advantage of this by altering the ansible_facts, such as ansible_hosts, users and any other key data which would lead into privilege escalation or code injection.

Affected products

How to fix

Upgrade to a fixed version: Red Hat Ansible 2.7.17, 2.8.9, 2.9.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-10684 or the next vulnerability affects your stack