What’s Vulnerable › Vulnerabilities
CVE-2020-10688
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-27 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) flaw was found in RESTEasy in versions before 3.11.1.Final and before 4.5.3.Final, where it did not properly handle URL encoding when the RESTEASY003870 exception occurs. An attacker could use this flaw to launch a reflected XSS attack.
Affected products
- Red Hat Fuse: 1.0
- Red Hat JBoss EAP: 7.3, 7.4
- RedHat Openshift Application Runtimes: all versions
- Red Hat, Inc. resteasy: before 3.11.1; from 4.5.0 before 4.5.3 — fixed in 3.11.1, 4.5.3
How to fix
Upgrade to a fixed version: Red Hat, Inc. resteasy 3.11.1, 4.5.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1814974
- https://github.com/quarkusio/quarkus/issues/7248
- https://issues.redhat.com/browse/RESTEASY-2519
- https://security.netapp.com/advisory/ntap-20210706-0008/
- https://bugzilla.redhat.com/show_bug.cgi?id=1814974
- https://github.com/quarkusio/quarkus/issues/7248
- https://issues.redhat.com/browse/RESTEASY-2519
- https://security.netapp.com/advisory/ntap-20210706-0008/
Get alerted when CVE-2020-10688 or the next vulnerability affects your stack