What’s Vulnerable › Vulnerabilities
CVE-2020-10697
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-27 · updated 2026-06-17
- Weakness: CWE-862
Description
A flaw was found in Ansible Tower when running Openshift. Tower runs a memcached, which is accessed via TCP. An attacker can take advantage of writing a playbook polluting this cache, causing a denial of service attack. This attack would not completely stop the service, but in the worst-case scenario, it can reduce the Tower performance, for which memcached is designed. Theoretically, more sophisticated attacks can be performed by manipulating and crafting the cache, as Tower relies on memcached as a place to pull out setting values. Confidential and sensitive data stored in memcached should not be pulled, as this information is encrypted. This flaw affects Ansible Tower versions before 3.6.4, Ansible Tower versions before 3.5.6 and Ansible Tower versions before 3.4.6.
Affected products
- Tower: before 3.4.6; from 3.5.0 before 3.5.6; from 3.6.0 before 3.6.4 — fixed in 3.4.6, 3.5.6, 3.6.4
How to fix
Upgrade to a fixed version: Tower 3.4.6, 3.5.6, 3.6.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1818445
- https://bugzilla.redhat.com/show_bug.cgi?id=1818445
Get alerted when CVE-2020-10697 or the next vulnerability affects your stack