What’s Vulnerable › Vulnerabilities
CVE-2020-10704
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-06 · updated 2026-06-17
- Weakness: CWE-674
Description
A flaw was found when using samba as an Active Directory Domain Controller. Due to the way samba handles certain requests as an Active Directory Domain Controller LDAP server, an unauthorized user can cause a stack overflow leading to a denial of service. The highest threat from this vulnerability is to system availability. This issue affects all samba versions before 4.10.15, before 4.11.8 and before 4.12.2.
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 30, 31
- openSUSE Leap: 15.2
- Samba: from 4.0.0 before 4.10.15; from 4.11.0 before 4.11.8; from 4.12.0 before 4.12.2 — fixed in 4.10.15, 4.11.8, 4.12.2
How to fix
Upgrade to a fixed version: Samba 4.10.15, 4.11.8, 4.12.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00054.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00002.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10704
- https://lists.debian.org/debian-lts-announce/2020/11/msg00041.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/U5KW3ZO35NVDO57JSBZHTQZOS3AIQ5QE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Y7DVGCHG3XPIBQ5ETGMGW7MXNOO4HFH4/
- https://security.gentoo.org/glsa/202007-15
- https://www.samba.org/samba/security/CVE-2020-10704.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00054.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00002.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10704
- https://lists.debian.org/debian-lts-announce/2020/11/msg00041.html
Get alerted when CVE-2020-10704 or the next vulnerability affects your stack