What’s Vulnerable › Vulnerabilities
CVE-2020-10709
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-27 · updated 2026-06-17
- Weakness: CWE-287
Description
A security flaw was found in Ansible Tower when requesting an OAuth2 token with an OAuth2 application. Ansible Tower uses the token to provide authentication. This flaw allows an attacker to obtain a refresh token that does not expire. The original token granted to the user still has access to Ansible Tower, which allows any user that can gain access to the token to be fully authenticated to Ansible Tower. This flaw affects Ansible Tower versions before 3.6.4 and Ansible Tower versions before 3.5.6.
Affected products
- Tower: before 3.5.6; from 3.6.0 before 3.6.4 — fixed in 3.5.6, 3.6.4
How to fix
Upgrade to a fixed version: Tower 3.5.6, 3.6.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1824033
- https://bugzilla.redhat.com/show_bug.cgi?id=1824033
Get alerted when CVE-2020-10709 or the next vulnerability affects your stack