What’s Vulnerable › Vulnerabilities
CVE-2020-10713
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-30 · updated 2026-06-17
- Weakness: CWE-120
Description
A flaw was found in grub2, prior to version 2.06. An attacker may use the GRUB 2 flaw to hijack and tamper the GRUB verification process. This flaw also allows the bypass of Secure Boot protections. In order to load an untrusted or modified kernel, an attacker would first need to establish access to the system such as gaining physical access, obtain the ability to alter a pxe-boot network, or have remote access to a networked system with root access. With this access, an attacker could then craft a string to cause a buffer overflow by injecting a malicious payload that leads to arbitrary code execution within GRUB. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- Debian Linux: 10.0
- grub2: before 2.06 — fixed in 2.06
- openSUSE Leap: 15.1, 15.2
- Photon OS: before 2.0 — fixed in 2.0
- Grub: All grub2 versions before 2.06
How to fix
Upgrade to a fixed version: grub2 2.06; Photon OS 2.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00017.html
- http://www.openwall.com/lists/oss-security/2020/07/29/3
- https://bugzilla.redhat.com/show_bug.cgi?id=1825243
- https://cve.openeuler.org/#/CVEInfo/CVE-2020-10713
- https://eclypsium.com/2020/07/29/theres-a-hole-in-the-boot/
- https://kb.vmware.com/s/article/80181
- https://security.gentoo.org/glsa/202104-05
- https://security.netapp.com/advisory/ntap-20200731-0008/
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-grub2-code-exec-xLePCAPY
- https://usn.ubuntu.com/4432-1/
- https://www.debian.org/security/2020/dsa-4735
Get alerted when CVE-2020-10713 or the next vulnerability affects your stack