What’s Vulnerable › Vulnerabilities
CVE-2020-10729
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-05-27 · updated 2026-06-17
- Weakness: CWE-330
Description
A flaw was found in the use of insufficiently random values in Ansible. Two random password lookups of the same length generate the equal value as the template caching action for the same file since no re-evaluation happens. The highest threat from this vulnerability would be that all passwords are exposed at once for the file. This flaw affects Ansible Engine versions before 2.9.6.
Affected products
- Debian Linux: 10.0
- RedHat Ansible Engine: before 2.9.6 — fixed in 2.9.6
How to fix
Upgrade to a fixed version: RedHat Ansible Engine 2.9.6. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1831089
- https://github.com/ansible/ansible/issues/34144
- https://www.debian.org/security/2021/dsa-4950
- https://bugzilla.redhat.com/show_bug.cgi?id=1831089
- https://github.com/ansible/ansible/issues/34144
- https://www.debian.org/security/2021/dsa-4950
Get alerted when CVE-2020-10729 or the next vulnerability affects your stack