What’s Vulnerable › Vulnerabilities
CVE-2020-10733
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-16 · updated 2026-06-17
- Weakness: CWE-426
Description
The Windows installer for PostgreSQL 9.5 - 12 invokes system-provided executables that do not have fully-qualified paths. Executables in the directory where the installer loads or the current working directory take precedence over the intended executables. An attacker having permission to add files into one of those directories can use this to execute arbitrary code with the installer's administrative rights.
Affected products
- PostgreSQL: from 9.5 before 9.5.22; from 9.6 before 9.6.18; from 10.0 before 10.13; from 11.0 before 11.8; from 12.0 before 12.3 — fixed in 10.13, 11.8, 12.3, 9.5.22, 9.6.18
How to fix
Upgrade to a fixed version: PostgreSQL 10.13, 11.8, 12.3, 9.5.22. Check the vendor advisory for mitigations.
References
- https://security.netapp.com/advisory/ntap-20201001-0006/
- https://www.postgresql.org/about/news/2038/
- https://www.postgresql.org/support/security/11/
- https://security.netapp.com/advisory/ntap-20201001-0006/
- https://www.postgresql.org/about/news/2038/
- https://www.postgresql.org/support/security/11/
Get alerted when CVE-2020-10733 or the next vulnerability affects your stack