What’s Vulnerable › Vulnerabilities
CVE-2020-10740
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-22 · updated 2026-06-17
- Weakness: CWE-502
Description
A vulnerability was found in Wildfly in versions before 20.0.0.Final, where a remote deserialization attack is possible in the Enterprise Application Beans(EJB) due to lack of validation/filtering capabilities in wildfly.
Affected products
- Wildfly: before 20.0.0 — fixed in 20.0.0
How to fix
Upgrade to a fixed version: Wildfly 20.0.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10740
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10740
Get alerted when CVE-2020-10740 or the next vulnerability affects your stack