What’s Vulnerable › Vulnerabilities
CVE-2020-10745
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-07 · updated 2026-06-17
- Weakness: CWE-400
Description
A flaw was found in all Samba versions before 4.10.17, before 4.11.11 and before 4.12.4 in the way it processed NetBios over TCP/IP. This flaw allows a remote attacker could to cause the Samba server to consume excessive CPU use, resulting in a denial of service. This highest threat from this vulnerability is to system availability.
Affected products
- Debian Linux: 9.0
- Fedoraproject Fedora: 31
- openSUSE Leap: 15.1, 15.2
- Samba: from 4.0.0 before 4.10.17; from 4.11.0 before 4.11.11; from 4.12.0 before 4.12.4 — fixed in 4.10.17, 4.11.11, 4.12.4
How to fix
Upgrade to a fixed version: Samba 4.10.17, 4.11.11, 4.12.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00030.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00054.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00002.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1849491%3B
- https://lists.debian.org/debian-lts-announce/2020/11/msg00041.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6YLNQ5GRXUKYRUAOFZ4DUBVN4SMTL6Q2/
- https://security.gentoo.org/glsa/202007-15
- https://www.samba.org/samba/security/CVE-2020-10745.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00030.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00054.html
- http://lists.opensuse.org/opensuse-security-announce/2020-09/msg00002.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1849491%3B
Get alerted when CVE-2020-10745 or the next vulnerability affects your stack