What’s Vulnerable › Vulnerabilities

CVE-2020-10755

Description

An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0 and all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0. When using openstack-cinder with the Dell EMC ScaleIO or VxFlex OS backend storage driver, credentials for the entire backend are exposed in the ``connection_info`` element in all Block Storage v3 Attachments API calls containing that element. This flaw enables an end-user to create a volume, make an API call to show the attachment detail information, and retrieve a username and password that may be used to connect to another user's volume. Additionally, these credentials are valid for the ScaleIO or VxFlex OS Management API, should an attacker discover the Management API endpoint. Source: OpenStack project

Affected products

How to fix

Upgrade to a fixed version: Red Hat openstack-cinder 14.1.0, 15.2.0, 16.1.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-10755 or the next vulnerability affects your stack