What’s Vulnerable › Vulnerabilities
CVE-2020-10756
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-09 · updated 2026-06-17
- Weakness: CWE-125
Description
An out-of-bounds read vulnerability was found in the SLiRP networking implementation of the QEMU emulator. This flaw occurs in the icmp6_send_echoreply() routine while replying to an ICMP echo request, also known as ping. This flaw allows a malicious guest to leak the contents of the host memory, resulting in possible information disclosure. This flaw affects versions of libslirp before 4.3.1.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 20.04
- Debian Linux: 9.0, 10.0
- Libslirp Project Libslirp: before 4.3.1 — fixed in 4.3.1
- openSUSE Leap: 15.0, 15.1
- Red Hat Enterprise Linux: 7.0, 8.0
- OpenStack: 13
How to fix
Upgrade to a fixed version: Libslirp Project Libslirp 4.3.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00040.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1835986
- https://lists.debian.org/debian-lts-announce/2020/07/msg00020.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JYTZ32P67PZER6P7TW6FQK3SZRKQLVEI/
- https://security.netapp.com/advisory/ntap-20201001-0001/
- https://usn.ubuntu.com/4437-1/
- https://usn.ubuntu.com/4467-1/
- https://www.debian.org/security/2020/dsa-4728
- https://www.zerodayinitiative.com/advisories/ZDI-20-1005/
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00040.html
Get alerted when CVE-2020-10756 or the next vulnerability affects your stack