What’s Vulnerable › Vulnerabilities
CVE-2020-10761
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-09 · updated 2026-06-17
- Weakness: CWE-617
Description
An assertion failure issue was found in the Network Block Device(NBD) Server in all QEMU versions before QEMU 5.0.1. This flaw occurs when an nbd-client sends a spec-compliant request that is near the boundary of maximum permitted request length. A remote nbd-client could use this flaw to crash the qemu-nbd server resulting in a denial of service.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 20.04
- openSUSE Leap: 15.2
- QEMU: before 5.0.1 — fixed in 5.0.1
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: QEMU 5.0.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00086.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10761
- https://security.gentoo.org/glsa/202011-09
- https://security.netapp.com/advisory/ntap-20200731-0001/
- https://usn.ubuntu.com/4467-1/
- https://www.openwall.com/lists/oss-security/2020/06/09/1
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00086.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10761
- https://security.gentoo.org/glsa/202011-09
- https://security.netapp.com/advisory/ntap-20200731-0001/
- https://usn.ubuntu.com/4467-1/
- https://www.openwall.com/lists/oss-security/2020/06/09/1
Get alerted when CVE-2020-10761 or the next vulnerability affects your stack