What’s Vulnerable › Vulnerabilities
CVE-2020-10824
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-26 · updated 2026-06-17
- Weakness: CWE-787
Description
A stack-based buffer overflow in /cgi-bin/activate.cgi through ticket parameter on Draytek Vigor3900, Vigor2960, and Vigor300B devices before 1.5.1 allows remote attackers to achieve code execution via a remote HTTP request (issue 2 of 3).
Affected products
- DrayTek Vigor2960: before 1.5.1 — fixed in 1.5.1
- DrayTek Vigor 300B: before 1.5.1 — fixed in 1.5.1
- DrayTek Vigor3900 Firmware: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: DrayTek Vigor2960 1.5.1; DrayTek Vigor 300B 1.5.1; DrayTek Vigor3900 Firmware 1.5.1. Check the vendor advisory for mitigations.
References
- https://slashd.ga/2020/03/draytek-vulnerabilities/
- https://www.draytek.com/about/security-advisory/vigor3900-/-vigor2960-/-vigor300b-stack-based-buffer-overflow-vulnerability/
- https://slashd.ga/2020/03/draytek-vulnerabilities/
- https://www.draytek.com/about/security-advisory/vigor3900-/-vigor2960-/-vigor300b-stack-based-buffer-overflow-vulnerability/
Get alerted when CVE-2020-10824 or the next vulnerability affects your stack