What’s Vulnerable › Vulnerabilities
CVE-2020-10931
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 28.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-24 · updated 2026-06-17
- Weakness: CWE-120
Description
Memcached 1.6.x before 1.6.2 allows remote attackers to cause a denial of service (daemon crash) via a crafted binary protocol header to try_read_command_binary in memcached.c.
Affected products
- Memcached: from 1.6.0 before 1.6.2 — fixed in 1.6.2
How to fix
Upgrade to a fixed version: Memcached 1.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/memcached/memcached/commit/02c6a2b62ddcb6fa4569a591d3461a156a636305
- https://github.com/memcached/memcached/issues/629
- https://github.com/memcached/memcached/wiki/ReleaseNotes162
- https://github.com/memcached/memcached/commit/02c6a2b62ddcb6fa4569a591d3461a156a636305
- https://github.com/memcached/memcached/issues/629
- https://github.com/memcached/memcached/wiki/ReleaseNotes162
Get alerted when CVE-2020-10931 or the next vulnerability affects your stack