What’s Vulnerable › Vulnerabilities
CVE-2020-10938
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-24 · updated 2026-06-17
- Weakness: CWE-190
Description
GraphicsMagick before 1.3.35 has an integer overflow and resultant heap-based buffer overflow in HuffmanDecodeImage in magick/compress.c.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- GraphicsMagick: before 1.3.35 — fixed in 1.3.35
- openSUSE Backports: sle-15-sp1
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: GraphicsMagick 1.3.35. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00049.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00051.html
- https://lists.debian.org/debian-lts-announce/2020/04/msg00007.html
- https://sourceforge.net/p/graphicsmagick/code/ci/5b4dd7c6674140a115ec9424c8d19c6a458fac3e/
- https://www.debian.org/security/2020/dsa-4675
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00049.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00051.html
- https://lists.debian.org/debian-lts-announce/2020/04/msg00007.html
- https://sourceforge.net/p/graphicsmagick/code/ci/5b4dd7c6674140a115ec9424c8d19c6a458fac3e/
- https://www.debian.org/security/2020/dsa-4675
Get alerted when CVE-2020-10938 or the next vulnerability affects your stack