What’s Vulnerable › Vulnerabilities
CVE-2020-10944
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-28 · updated 2026-06-17
- Weakness: CWE-79
Description
HashiCorp Nomad and Nomad Enterprise up to 0.10.4 contained a cross-site scripting vulnerability such that files from a malicious workload could cause arbitrary JavaScript to execute in the web UI. Fixed in 0.10.5.
Affected products
- HashiCorp Nomad Enterprise: from 0.3 before 0.10.5 — fixed in 0.10.5
How to fix
Upgrade to a fixed version: HashiCorp Nomad Enterprise 0.10.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-10944 or the next vulnerability affects your stack