What’s Vulnerable › Vulnerabilities
CVE-2020-11001: Possible XSS attack in Wagtail
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-14 · updated 2026-06-17
- Weakness: CWE-79
Description
In Wagtail before versions 2.8.1 and 2.7.2, a cross-site scripting (XSS) vulnerability exists on the page revision comparison view within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft a page revision history that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 2.7.2 (for the LTS 2.7 branch) and Wagtail 2.8.1 (for the current 2.8 branch).
Affected products
- wagtail: from 1.9 through 2.7.1; 2.8
References
- https://github.com/wagtail/wagtail/security/advisories/GHSA-v2wc-pfq2-5cm6
- https://github.com/wagtail/wagtail/commit/61045ceefea114c40ac4b680af58990dbe732389
- https://github.com/wagtail/wagtail/releases/tag/v2.8.1
- https://github.com/wagtail/wagtail/security/advisories/GHSA-v2wc-pfq2-5cm6
Get alerted when CVE-2020-11001 or the next vulnerability affects your stack