What’s Vulnerable › Vulnerabilities
CVE-2020-11002: Remote Code Execution (RCE) vulnerability in dropwizard-validation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-10 · updated 2026-06-17
- Weakness: CWE-74
Description
dropwizard-validation before versions 2.0.3 and 1.3.21 has a remote code execution vulnerability. A server-side template injection was identified in the self-validating feature enabling attackers to inject arbitrary Java EL expressions, leading to Remote Code Execution (RCE) vulnerability. If you are using a self-validating bean an upgrade to Dropwizard 1.3.21/2.0.3 or later is strongly recommended. The changes introduced in Dropwizard 1.3.19 and 2.0.2 for CVE-2020-5245 unfortunately did not fix the underlying issue completely. The issue has been fixed in dropwizard-validation 1.3.21 and 2.0.3 or later. We strongly recommend upgrading to one of these versions.
Affected products
- dropwizard: before 1.3.21; from 2.0.0 before 2.0.3 — fixed in 1.3.21, 2.0.3
How to fix
Upgrade to a fixed version: dropwizard 1.3.21, 2.0.3. Check the vendor advisory for mitigations.
References
- https://docs.jboss.org/hibernate/validator/6.1/reference/en-US/html_single/#section-hibernateconstraintvalidatorcontext
- https://github.com/dropwizard/dropwizard/commit/d5a512f7abf965275f2a6b913ac4fe778e424242
- https://github.com/dropwizard/dropwizard/pull/3208
- https://github.com/dropwizard/dropwizard/pull/3209
- https://github.com/dropwizard/dropwizard/security/advisories/GHSA-3mcp-9wr4-cjqf
- https://github.com/dropwizard/dropwizard/security/advisories/GHSA-8jpx-m2wh-2v34
- https://github.com/dropwizard/dropwizard/security/policy#reporting-a-vulnerability
- https://docs.jboss.org/hibernate/validator/6.1/reference/en-US/html_single/#section-hibernateconstraintvalidatorcontext
- https://github.com/dropwizard/dropwizard/commit/d5a512f7abf965275f2a6b913ac4fe778e424242
- https://github.com/dropwizard/dropwizard/pull/3208
- https://github.com/dropwizard/dropwizard/pull/3209
- https://github.com/dropwizard/dropwizard/security/advisories/GHSA-3mcp-9wr4-cjqf
Get alerted when CVE-2020-11002 or the next vulnerability affects your stack