What’s Vulnerable › Vulnerabilities
CVE-2020-11020: Authentication and extension bypass in Faye
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-29 · updated 2026-06-17
- Weakness: CWE-287
Description
Faye (NPM, RubyGem) versions greater than 0.5.0 and before 1.0.4, 1.1.3 and 1.2.5, has the potential for authentication bypass in the extension system. The vulnerability allows any client to bypass checks put in place by server-side extensions, by appending extra segments to the message channel. It is patched in versions 1.0.4, 1.1.3 and 1.2.5.
Affected products
- Faye: from 0.5.0 (excl.) before 1.0.4; from 1.1.0 before 1.1.3; from 1.2.0 before 1.2.5 — fixed in 1.0.4, 1.1.3, 1.2.5
How to fix
Upgrade to a fixed version: Faye 1.0.4, 1.1.3, 1.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/faye/faye/commit/65d297d341b607f3cb0b5fa6021a625a991cc30e
- https://github.com/faye/faye/security/advisories/GHSA-qpg4-4w7w-2mq5
- https://github.com/faye/faye/commit/65d297d341b607f3cb0b5fa6021a625a991cc30e
- https://github.com/faye/faye/security/advisories/GHSA-qpg4-4w7w-2mq5
Get alerted when CVE-2020-11020 or the next vulnerability affects your stack