What’s Vulnerable › Vulnerabilities

CVE-2020-11022: jQuery has a potential XSS vulnerability

Description

In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

Affected products

How to fix

Upgrade to a fixed version: Drupal 7.70, 8.7.14, 8.8.6; jQuery 3.5.0; Oracle Blockchain Platform 21.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-11022 or the next vulnerability affects your stack