What’s Vulnerable › Vulnerabilities
CVE-2020-11029: Cross-site scripting in stats method (object cache) in WordPress
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-30 · updated 2026-06-17
- Weakness: CWE-79
Description
In affected versions of WordPress, a vulnerability in the stats() method of class-wp-object-cache.php can be exploited to execute cross-site scripting (XSS) attacks. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- WordPress: from 3.7 before 3.7.33; from 3.8 before 3.8.33; from 3.9 before 3.9.31; from 4.0 before 4.0.30; from 4.1 before 4.1.30; from 4.2 before 4.2.27 — fixed in 3.7.33, 3.8.33, 3.9.31, 4.0.30, 4.1.30, 4.2.27
How to fix
Upgrade to a fixed version: WordPress 3.7.33, 3.8.33, 3.9.31, 4.0.30. Check the vendor advisory for mitigations.
References
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-568w-8m88-8g2c
- https://lists.debian.org/debian-lts-announce/2020/05/msg00011.html
- https://wordpress.org/support/wordpress-version/version-5-4-1/#security-updates
- https://www.debian.org/security/2020/dsa-4677
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-568w-8m88-8g2c
- https://lists.debian.org/debian-lts-announce/2020/05/msg00011.html
- https://wordpress.org/support/wordpress-version/version-5-4-1/#security-updates
- https://www.debian.org/security/2020/dsa-4677
Get alerted when CVE-2020-11029 or the next vulnerability affects your stack